Sie sind nicht angemeldet.

26

Montag, 13. April 2020, 10:53

Der Durchgangsprüfer sagt der linke Pin mit den 3,3V führt tatsächlich zu TPS51225 und der rechte Pin führt zu 8 Pins am EC.

An dieser Stelle möchte ich allen recht herzlich danken für die tolle Hilfe ! Vielen Dank !

Ich bin nun mit meinen Möglichkeiten am Ende angekommen und muss das Board an die Profis hier weiter reichen.

27

Montag, 13. April 2020, 13:45

Mit "eher unwahrscheinlich" meinte ich die Kerkos an der EC Versorgung.

Gibt es eigentlich Infos, warum die EC so gerne sterben?
Als 8 Bit MCU mit 128k Flash ist da ja eher ein Low Level Prozessor. Der sollte eigentlich ewig laufen.
Das sind dann wohl die Unterschiede zwischen Automotive und Consumer...

Der defekt am Batterie Controller ist wohl ein Folgefehler.
Bei der zweiten Messung am Batterie Controller lagen am I2C Bus (SDA) 1,5V an. Das ist genau der verbotene Bereich der Digitalsignale und killt dann die Eingangsstufe am Batterie Controller.

28

Montag, 13. April 2020, 14:21

Also meinerseits kann ich dazu leider nichts sagen, da ich das Notebook bei Ebay ersteigert habe mit der Beschreibung plötzlich keine Reaktion. Mehr hat der Verkäufer auch nicht verraten.

EDV-Dompteur

Administrator

Beiträge: 1 566

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

29

Montag, 13. April 2020, 14:51

Gibt es eigentlich Infos, warum die EC so gerne sterben?
Als 8 Bit MCU mit 128k Flash ist da ja eher ein Low Level Prozessor. Der sollte eigentlich ewig laufen.
Das wundert mich auch schon lange!
Wenn ich da an die populären Atmel AVR denke - die haben bei mir den Ruf, unkaputtbare Arbeitstiere zu sein.

Allerdings werden AVRs in den meisten Schaltungen per Linearregler betrieben. Das ist an zuverlässigkeit kaum zu toppen.
Die Embedded Controller in Notebooks hingegen, bekommen zusätzlich zur 3,3V-Spannung aus dem LDO auch noch Spannung aus einem Schaltregler.
Wenn sich also der Schaltregler mal kurz verschluckt, dann mag es sein, dass der EC ruckzuck Schaden nimmt.


Der defekt am Batterie Controller ist wohl ein Folgefehler.
Ich glaube eher, es war umgekehrt:
Zuerst spackte der Ladecontroller ab und schaltete die Eingangs-MOSFETs "flatternd" durch.
Daraufhin verschluckte sich der 3,3V Schaltwandler und killte dadurch den EC (ohne eigenen Schaden zu erleiden).
Der nun defekte EC lutschte fortan einen zu hohen Strom aus dem LDO, so dass der TPS heiß wurde.

Deine Vermutung erscheint mir ausgeschlossen, dass die Spannung im "verbotenen" Bereich auf SDA die Eingangsstufe des Ladecontroller killte.
Ich bin nicht allwissend, habe aber noch nie davon gehört oder gelesen, dass man eine digitale Eingangsstufe mit unzulässigem Logikpegel killen könnte.
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte möglichst öffentlich im Forum stellen! -
Telefonische Reparaturtipps sind ab sofort kostenpflichtig, siehe hier:
https://www.edv-dompteur.de/forum/index.…ad&threadID=504

30

Montag, 13. April 2020, 15:07

Gibt es eigentlich Infos, warum die EC so gerne sterben?
Man muss hier nicht wirklich nach Gründe suchen. Mit der Zeit bekam der EC (damals KBC) immer mehr Aufgaben, heutzutage es ist das wichtigste Bauteil am Board. Anfänglich war es nur für die Tastatur zuständig (hieß noch KBC) und einige Board konnte sogar ganz ohne funktionieren. Jetzt findet man kaum ein Bauteil am Mainboard der irgendwie nicht mit der EC etwas zu tun hat, so die Fehlerursachen sind auch extrem vielfältig. Geht der EC aus irgendeine Grund kaputt und man misst am Board überall verrückte Werte, die meistens nach dem Entfernen des ECs verschwinden. Ich möchte hier nicht auflisten was alles es tut, hier kannst Du nachlesen:
https://en.wikipedia.org/wiki/Embedded_controller


...und wie erwähnt wurde, es platzt oft auch gerne auf. Mein Fotos die ich so aufs schnelle gefunden habe:








31

Montag, 13. April 2020, 15:32

Deine Vermutung erscheint mir ausgeschlossen, dass die Spannung im "verbotenen" Bereich auf SDA die Eingangsstufe des Ladecontroller killte.
Es geht um den Shoot-through current. Den gibt es bei jeder CMOS Schaltung.
https://e2e.ti.com/support/logic/f/151/t…-a-CMOS-device-
Die MOSFETs der CMOS Stufen sind relativ schwach ausgelegt (es sind ja keine Leistungsbauteile) und vertragen daher auch nicht viel Querstrom.
Die Embedded Controller in Notebooks hingegen, bekommen zusätzlich zur 3,3V-Spannung aus dem LDO auch noch Spannung aus einem Schaltregler.
Ja, aber der Schaltregler versorgt nicht die Standby Teile des EC.
Vermutlich ist es eher eine Alterungsgeschichte. Der EC ist auch im Ruhezustand immer an Spannung (wohl auch in der S5 Konfiguration).
Wenn dann noch Feuchtigkeit in den Chip eindringen kann, weil nicht gut vergoßen, dann fängt das an zu arbeiten. Meine Vermutung...
Ist hald eine Qualitäts- bzw. Preisfrage und das Teil soll ja nicht ewig halten.

Ein Verschlucken des Schaltregler kenne ich nicht. Wenn dann ist es eine schlechte Auslegung des Regelverhaltens (Spannungssprünge am Eingang, Lastsprünge am Ausgang).
Zudem müssten auch andere Bauteile defekt gehen und nicht immer nur der EC.

32

Montag, 13. April 2020, 15:37

Kann es sein, dass es meist der selbe Chiphersteller iTE ist?
Der Lenovo Chip scheint auch nur gebrandet zu sein.
Möglich wäre natürlich auch eine schlechte Schutzbeschaltung. Ein ESD Puls der bis zum Chip durchdringt. Wobei die Pins eigentlich oft auch ESD Schutzschaltungen integriert haben.

33

Montag, 13. April 2020, 15:46

Kann es sein, dass es meist der selbe Chiphersteller iTE ist?
Nur zufällig solche Fotos gefunden, ENE, Nuvoton und SMSC gehen genauso kaputt. Es ist aber auch irgendwie richtig, so ganz sichtbar gebrannt geht der EC öfter im Lenovos kaputt (und da wird meist ITE verwendet, gebrandet oder nicht), und meist wegen die ungeschützte Netzteil-ID Leitung von Netzbuchse.

EDV-Dompteur

Administrator

Beiträge: 1 566

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

34

Montag, 13. April 2020, 16:10

Es geht um den Shoot-through current. Den gibt es bei jeder CMOS Schaltung.
https://e2e.ti.com/support/logic/f/151/t…-a-CMOS-device-
OK, das ist ein Argument.


Ja, aber der Schaltregler versorgt nicht die Standby Teile des EC.
Jain.
Es ist so, dass der 3,3V-Schaltregler (wie auch der für 5V) sofort nach Einstecken des 19V-Steckers ins Notebook losrennt.
Wenn die zugeführte Spannung nun aber flattert, z. B. weil die Eingangs-MOSFETs nicht sauber durchschalten, dann startet und stoppt der Schaltwandler mit hoher Frequenz immer wieder. Dabei kann sonstwas passieren.
Natürlich haben Schaltregler-ICs reichlich Schutzmechanismen integriert, um solche Fälle möglichst abzufangen. Aber zaubern können die auch nicht, wenn die Eingangsspannung völlig verrückt spielt.


Ein Verschlucken des Schaltregler kenne ich nicht. Wenn dann ist es eine schlechte Auslegung des Regelverhaltens (Spannungssprünge am Eingang, Lastsprünge am Ausgang).
Doch, das gibt es. Und dafür gibt es sogar mehrere ganz unterschiedliche Gründe.
Es gibt allerhand unappetitliche Effekte bei Schaltwandlern, die in Sondersituationen auftreten können.
Manche davon resultieren aus schlechter Masseführung, bzw. generell der Layoutführung. Allerdings hat man damit eher bei zweiseitigen Layouts zu kämpfen, als bei Multilayern.
Die Ströme, die an manchen Stellen des Mainboards auftreten, können dutzende Ampere betragen. Da kann ein Peak zur falschen Zeit an anderer Stelle das Massepotential verschieben, was dann vielfältige Auswirkungen haben kann.

Wenn die Last zuerst starken Strom zieht, so dass der Regler ordentlich hochregeln will und in diesem Moment die Last hochohmig wird - womöglich garniert mit einem von einem anderen Schaltwandler erzeugten Strompeak, der das Massepotential derart verschiebt, dass der Regler nicht sofort mitkriegt, was los ist - dann kann die Spannung schon mal ganz kurz höher gehen, als der Regler es normalerweise erlauben würde.

Der Effekt wird umso drastischer, je weiter die Last von der Spannungsquelle entfernt sitzt, denn dann kann es passieren, dass der Schaltregler seinen Job perfekt macht, aber die zuerst niederohmige und plötzlich hochohmige Last dennoch einen Spannungspeak abbekommt.
Klar, dafür gibt es reichlich Entkoppelkondensatoren auf dem gesamten MB an strategischen Stellen, um sowas weg zu schlucken. Aber die sind halt dafür ausgelegt, die denkbaren Fälle abzudecken.
Wenn mal ein wirklich exotischer Fall eintritt, wie flatternde Eingangs-MOSFETs, dann würde ich für nichts garantieren.
Eine gut ausgelegte Schaltung, mit gutem Layout, sollte natürlich immun gegen all sowas sein. Aber glaubst Du daran, dass jedes Mainboard-Design absolut perfekt ist?


Zudem müssten auch andere Bauteile defekt gehen und nicht immer nur der EC.
Das schwächste Glied einer Kette bricht stets zuerst.
Wenn der EC dann mit Kurzschluss defekt ist, schützt er die übrigen Bauteile in "patriotischer Selbstopferung", wie ich es gerne scherzhaft nenne.
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte möglichst öffentlich im Forum stellen! -
Telefonische Reparaturtipps sind ab sofort kostenpflichtig, siehe hier:
https://www.edv-dompteur.de/forum/index.…ad&threadID=504

35

Montag, 13. April 2020, 22:45

Wenn die zugeführte Spannung nun aber flattert, z. B. weil die Eingangs-MOSFETs nicht sauber durchschalten, dann startet und stoppt der Schaltwandler mit hoher Frequenz immer wieder.
MOSFETs flattern nicht. Du meinst vielleicht einen Wackelkontakt. Dafür muss die Spannungsregelung aber ausgelegt sein.
Schaltregler starten und stoppen auch nicht mit hoher Frequenz. Das ist auch gar nicht notwendig und selbst wenn, muss sich der Stromfluss in der Spule auch erst wieder aufbauen und das erfolgt geregelt (Softstart ist da auch noch so ein Schlagwort).
Die Pufferung der Versorgung führt zudem dazu, dass die Spannung nicht schlagartig einbricht.
Das LC Glied im Schaltregler wirkt zudem als Tiefpass. Das dämpft schon einiges an Rippel weg.

Das Layout und vor allem die Masse spielen auch eine große Rolle. Ich gehe bei den Mainboards aber mal mindestens von 2 kompletten GND Planes aus.
Die sind schon wg. den ganzen impedanzkontrollierten Signalen und den hohen Strömen am Prozessor notwendig.

Gut, das ist jetzt der Idealfall...
Bei Designfehlern und geringer Testtiefe können schon mal Schwachstellen der Schaltung durchschlüpfen. Sparfüchse sind dann natürlich auch unterwegs.

@Sleepygti: Ich bin in Theorie und Praxis unterwegs. Die HW die ich entwickle wird später durch zig Tests abgetestet. Die Anforderungen im Automobilbereich sind da eine ganz andere Hausnummer, als bei einem Laptop. Alleine schon die Qualifizierung der Chips nach AEC-Q.
Was mich interessieren würde. Wo bekommt man die SW für den EC her oder ist das die BIOS SW die man als Update beim Hersteller runterladen kann?

36

Dienstag, 14. April 2020, 00:48

@Sleepygti: Ich bin in Theorie und Praxis unterwegs. Die HW die ich entwickle wird später durch zig Tests abgetestet. Die Anforderungen im Automobilbereich sind da eine ganz andere Hausnummer, als bei einem Laptop. Alleine schon die Qualifizierung der Chips nach AEC-Q.
Was mich interessieren würde. Wo bekommt man die SW für den EC her oder ist das die BIOS SW die man als Update beim Hersteller runterladen kann?
Es ist ja "tricky". Es gibt kein allgemeine Antwort auf diese Frage.

- man findet im Netz, es sind Seiten, Foren und Facebook Gruppen die sowas verkaufen oder kostenlos anbieten wenn man Glück hat...;
- es sind Boards, wo der EC Firmware in ein separate EEprom gespeichert ist und der EC programmiert sich selbst beim Start auf;
- im andere Fälle das Firmware aus dem BIOS Dump mit HEX Editor ausschneidbar ist;
- im wenige Fälle der Update File beinhaltet neben der BIOS Region auch das EC Firmware und man kann daraus extrahieren;
- man baut sich selbst einen Database auf. Es kommt ein Notebook ein, ich weiß dass dessen Firmware noch im Netz nicht erreichbar ist und ich lese den für mich aus...
- im allerletzte Fall -ja es ist ehmm- man bestellt ein passende Mainboard, liest das Firmware aus /durch Tastaturanschluss also es wird nichts beschädigt/ und schickt das Board zurück :)


Es sind mehrere Modellen, wo sogar das BIOS Passwort in der EC gespeichert ist, es sind Boards wo das Firmware(BIOS, EC, ME, Security...) in 3-4 EEprom geteilt ist und nur zusammengefügt kann man bearbeiten.

Wenn es noch nicht genug wäre, mit der neue Modellen kommen immer wieder weitere Änderungen-Neuigkeiten, dann sitzt man doof davor...hähh? Google hilft erst wenn das Gerät schon etwas älter ist, von Herstellern bekommt man keine Hilfe

EDV-Dompteur

Administrator

Beiträge: 1 566

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

37

Dienstag, 14. April 2020, 06:03

MOSFETs flattern nicht. Du meinst vielleicht einen Wackelkontakt.
Wir hatten am Anfang dieses Threads einen defekten Ladecontroller.
Kannst Du sagen, was der im Sterbevorgang noch gemacht hat?
Das Thema Wackelkontakt (an der 19V-Buchse) kommt noch hinzu - ein WK könnte eventuell den Tod des Ladecontrollers verschuldet haben.
Darf zwar theoretisch nicht sein, aber der Ladecontroller war nunmal kaputt.


Schaltregler starten und stoppen auch nicht mit hoher Frequenz.
Ja, im Normalfall nicht. Dafür sorgen die ganzen Schutzmechanismen. Eigentlich ...
Aber das, worüber wir hier reden, ist doch im Grunde eine ganz ähnliche Angelegenheit wie das, was Du mir selbst zuvor verlinkt hast, mit den sterbenden CMOS-Eingangsstufen bei floatendem Eingangssignal. Wir reden über einen Sonderfall, der völlig außerhalb der normalen Betriebsumstände liegt.

Wenn (warum auch immer) die 19V Versorgungsspannung einige Zeit "flattert", dann werden die davon versorgten Schaltwandler-Chips (auch der Ladecontroller) unter Umständen verrückt spielen können - trotz Schutzmechanismen.
Du kannst ja spaßeshalber mal ein Oszi an den Ausgang des 3,3V Schaltreglers hängen und statt der beiden Eingangs-MOSFETs ein flatterndes Relais nach Art eines Wagnerschen Hammers anschließen. Optimal für diesen Test wäre es, wenn auch die Frequenz des Wagnerschen Hammers eingestellt werden könnte.
- Würdest Du wirklich dafür garantieren und Deine Hand dafür ins Feuer legen, dass sich dabei unter gar keinen Umständen (egal mit welcher Frequenz der Hammer hämmert) niemals ein kurzer Überspannungs-Peak am Ausgang des 3,3V-Schaltwandlers ergeben kann?
- Also ich würde an Deiner Stelle nicht einen Cent darauf wetten!

Ich kann es gerade leider nicht belegen, aber ich würde schwören, am 3,3V Schaltwandler-Ausgang schon kurze "Verschlucker" mit Überspannung gesehen zu haben, wenn es an der Eingangsbuchse "brutzelte", im Moment des Steckens/Ziehens/Wackelns.
Quantifizieren kann ich es nicht, es war zu kurz und mehr aus den Augenwinkeln gesehen. Und den EC hat es da auch nicht gegrillt, aber ein ungutes Gefühl war es!


Das ist auch gar nicht notwendig und selbst wenn, muss sich der Stromfluss in der Spule auch erst wieder aufbauen und das erfolgt geregelt (Softstart ist da auch noch so ein Schlagwort).
Die Pufferung der Versorgung führt zudem dazu, dass die Spannung nicht schlagartig einbricht.
Das LC Glied im Schaltregler wirkt zudem als Tiefpass. Das dämpft schon einiges an Rippel weg.
Und so weiter und so weiter - ja, wie ich ja selbst schrieb, gibt es etliche Schutzmechanismen ... und Entkoppelkondensatoren ... und Filter ... und hast-nicht-gesehen watt für Schutzmaßnahmen, die im Normalfall jeden in der Praxis auftretenden Dreck weg stecken.
Wäre es anders, dann würde ein Notebook keinen einzigen normalen Arbeitstag überleben.
Trotzdem sterben Notebooks dauernd. Warum tun die das?
Übrigens tun sie das meistens nicht im laufenden Betrieb, sondern meistens beim Einschalten, oder beim Einstecken des 19V-Steckers. Warum?

Warum sterben so häufig die Eingangs-MOSFETs?
Warum stirbt gelegentlich der Ladecontroller?
Warum sterben so häufig die Schaltwandler-MOSFETs?
Warum sterben gelegentlich die Schaltwandler-ICs?
Warum stirbt gelegentlich ein Embedded Controller?
Warum sterben sehr häufig Kerkos (auch an mechanisch unbelasteten Stellen)?

All diese Bauteile sind doch dafür ausgelegt, alles wegzustecken, was im Normalfall vorkommen kann, oder?
Und dann sind da obendrein doch auch noch diese vielen tollen Softstart-Mechanismen, gelle?
Und die MOSFETs haben doch eigentlich sogar eine ziemlich kräftige Reserve, oder?

Weiterhin: Warum gibt es gar nicht mal selten Folgeschäden, wie auch hier?
Hier war der Ladecontroller defekt UND der Embedded Controlller! Warum?
Zwischen dem Ladecontroller und dem Embedded Controller sitzt doch ein superguter Puffer, in Form des 3,3V Schaltwandlers, mit all seinen tollen Schutzmechanismen!
Dürfte doch gar nicht sein!


Jaja, vielleicht war es umgekehrt - so wie Du es vermutetst - und zuerst ist der EC verreckt, dessen dann kränkelnde Ausgangssignale in Folge den I2C-Eingang des Ladecontrollers gekillt haben.
Es kommt mir zwar unwahrscheinlich vor, dass der Ladecontroller dann auf solche Weise verrückt spielt, dass es dauerhaft seine Ladungspumpe abschaltet. Aber wer weiß?
- Ist aber auch wurscht, denn auch dieser Fall wäre ein Folgeschaden. Sprich: Ein extremer Sonderfall an der einen Stelle bewirkt einen Defekt an anderer (nicht vorhergesehener) Stelle.
Und da haben wir es! Die Entwickler fangen eben NICHT jeden exotischen Sonderfall ab!
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte möglichst öffentlich im Forum stellen! -
Telefonische Reparaturtipps sind ab sofort kostenpflichtig, siehe hier:
https://www.edv-dompteur.de/forum/index.…ad&threadID=504

EDV-Dompteur

Administrator

Beiträge: 1 566

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

38

Dienstag, 14. April 2020, 06:14

man baut sich selbst einen Database auf.
Ein echt prima Posting, Sleepygti!
Da hast Du mal sehr schön die grausamen Schwierigkeiten aufgelistet, mit denen man es zu tun haben kann, um überhaupt auch nur an die nötigen Firmware-Dateien zu kommen (die dann ja immer noch nicht gebrannt sind ...).

Aber eine Frage zu Deiner Database: Wie verwaltest Du die? Welche Software verwendest Du, um den Überblick über die ganzen Dateien zu behalten?
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte möglichst öffentlich im Forum stellen! -
Telefonische Reparaturtipps sind ab sofort kostenpflichtig, siehe hier:
https://www.edv-dompteur.de/forum/index.…ad&threadID=504

39

Dienstag, 14. April 2020, 10:37

Wie verwaltest Du die? Welche Software verwendest Du, um den Überblick über die ganzen Dateien zu behalten?
Das Programm heißt: Windows-Explorer :)
Ich verwende kein extra System dafür... Unterordnern richtig mit Marke, Modell und Mainboardbezeichnung benennen und fertig.

EDV-Dompteur

Administrator

Beiträge: 1 566

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

40

Dienstag, 14. April 2020, 13:42

Das Programm heißt: Windows-Explorer :)
Ich verwende kein extra System dafür... Unterordnern richtig mit Marke, Modell und Mainboardbezeichnung benennen und fertig.
OK, prinzipiell genauso mache ich es auch. Aber ich bin unzufrieden damit, weil so ein System allerlei Begrenzungen hat.
Eine echte Datenbank wäre viel besser, darum schrieb ich ja auch mal die zu Testimedes gehörende Mainboardverwaltung. Nur ist die "gegenwärtig" (schon lange) in einem unbenutzbaren Zustand. :-(
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte möglichst öffentlich im Forum stellen! -
Telefonische Reparaturtipps sind ab sofort kostenpflichtig, siehe hier:
https://www.edv-dompteur.de/forum/index.…ad&threadID=504

41

Dienstag, 14. April 2020, 17:14

Ja, so ähnlich hatte ich mir das mit der EC SW schon vorgestellt.
Bin sogar überrascht, dass sich die SW auslesen lässt. Normalerweise sperrt man ja entsprechende Schnittstellen oder hat einen securtiy access; dann kann man den Prozessor nur noch platt machen und neu flashen, was aber hier nicht das Ziel ist.

42

Samstag, 18. April 2020, 21:42

Also irgendwie bin ich noch nicht ganz zufrieden mit der Situation. Undzwar ist mir aufgefallen, dass an manchen Stellen so wie in der Grafik mit einem runden Kreis markiert, die Spannung nicht übereinstimmt mit dem funktionierenden Board. Bei dem voll funktionierenden Board sind dort um die 12V messbar und bei dem defekten Board um die 19V das macht mich ein wenig stutzig. Achso und der TPS wird immer noch heiß ob mit Ferid oder ohne.
Könnte es eventuell doch noch einen anderen Grund geben ???


43

Sonntag, 19. April 2020, 08:34

Guten Morgen,
Es ist ja "tricky". Es gibt kein allgemeine Antwort auf diese Frage.

- man findet im Netz, es sind Seiten, Foren und Facebook Gruppen die sowas verkaufen oder kostenlos anbieten wenn man Glück hat...;
- es sind Boards, wo der EC Firmware in ein separate EEprom gespeichert ist und der EC programmiert sich selbst beim Start auf;
- im andere Fälle das Firmware aus dem BIOS Dump mit HEX Editor ausschneidbar ist;
- im wenige Fälle der Update File beinhaltet neben der BIOS Region auch das EC Firmware und man kann daraus extrahieren;
- man baut sich selbst einen Database auf. Es kommt ein Notebook ein, ich weiß dass dessen Firmware noch im Netz nicht erreichbar ist und ich lese den für mich aus...
- im allerletzte Fall -ja es ist ehmm- man bestellt ein passende Mainboard, liest das Firmware aus /durch Tastaturanschluss also es wird nichts beschädigt/ und schickt das Board zurück :)
Sehr aufschlussreich, habe mir diese Frage gestern auch gestellt. Und dachte bis dato, das Ihr wo dies (Hauptberuflich?) macht evtl. einen Zugang zu den Herstellern habt. Wirklich schade, bin schon länger der Meinung dass es eine Pflicht geben sollte nach gewisser Zeit dinge offen zu legen. Dachte hierbei mehr an Alte Maschinen z.B. nach 20 Jahren? Bei Consumer müssste dies eigentlich schon nach 3 Jahren erfolgen. Also in anbetracht der Tatsache wie dort die Lebenszyklen sind. Habe seit Jahren eine defekte Werkstatt Maschine stehen und davon gut 10-20 ROM dumps die alle unterschiedlich sind... Nun fehlt mir ausgerechnet die entscheidente Firmware das, dass Gerät wieder laufen würden und ich weiß nicht ob ich aus den Dumps was rekonstruieren könnte. Echt gemein sowas.
Aber eine Frage zu Deiner Database: Wie verwaltest Du die? Welche Software verwendest Du, um den Überblick über die ganzen Dateien zu behalten?

Hier würde ich gerne etwas 2nd Hand Erfahrung anbieten. Mein Bruder nutzt seit Jahren Evernote. Hier kann er Informationen aller Art ablegen, JPG, PDF, Doc etc.. Datein die nicht als Text vorliegen werden OCR gescannt und sind so voll durchsuchbar. Beispiel du hast einen IC-XY dieser ist anders beschaltet als man vom Datenblatt erwarten würde. Eine kurze Suche nach IC-XY in Evernote verät dir, dass der selbe IC auch in einen HP Notebooktyp zu sitzt. Und mit etwas Glück ist er dort so beschalten wie im dir vorliegenden Fall. Das besondere ist, dass auch alte Datenblätter um die Jahrtausenwende die nicht als Text vorliegen und nicht durchsuchbar sind als OCR gescannt werden und so durchsuchbar werden! Das selbe gilt für Bilder mit Textinhalt. Dieser Text wird ebenfalls durchsuchbar und erleichtert dir in vielen Jahren die Suche. Evernote ist also ein Tool und Dienst mit online Datenbank (geht auch offline!), um Inhalte aller Art zu sortieren, abzulegen und bei Bedarf schneller wiederzufinden. Evernote läuft natürlich auch als App auf dem Smartphone und du kannst Mails mit Datenblättern direkt an Evernote senden, so werden Sie in deiner Datenbank eingebunden. Einfach mal ein YouTube Video dazu ansehen, wie Leistungsfähig das ganze ist. Die Basis Variante ist kostenfrei, mein Bruder nutzt bereits Business. Kann hier leider nicht auf Anhieb sagen wo die Einschränkungen liegen.

Testimedes
Würdest du mich kurz erhellen, um was geht es dabei? Evtl. ein Link?

Bei dem voll funktionierenden Board sind dort um die 12V messbar und bei dem defekten Board um die 19V das macht mich ein wenig stutzig.

Zu aller erst würde ich annehmen, du misst den einen im Netzbetrieb und den anderen auf Akkubetrieb? Akku bei 70-80% und 4 Zellen => 4x 4,0V sind etwa deine gemessenen 12V. Hast du dich da vielleicht selbst hereingelegt?
Gruß Apfel

44

Sonntag, 19. April 2020, 10:13

Nein es ist definitiv kein Akku dran. Ich lasse den Akku erstmal weg.

Ganz merkwürdig finde ich die Werte direkt neben dem TPS rechts daneben befindet sich ich glaube ein Kerko bei dem Funktionierenden Board sind dort von links 5,1V und rechts 10,8V und bei dem Defekten Board kommt von links garnichts und rechts 1V. Ich werde mal den TPS an sich austauschen ich vermute der ist hinüber.

45

Sonntag, 19. April 2020, 11:57

neben dem TPS rechts daneben befindet sich ich glaube ein Kerko
Das sind schaltende Spannungen des Schaltreglers. Mit Multimeter gemessen sind die wenig aussagekräftig. Sieht wohl aber danach aus, dass der 5V Schaltregler am defekten Board nicht aktiv ist (wird vom EC aktiviert).
der TPS wird immer noch heiß
Mit und ohne Ferrit...
Dann mal alle 4 Ausgangsspannungen des TPS messen. Pin 2, 3,4 und 13.
Dann noch die Enable Signale dazu Pin 6 und 20.
Die 12V (+12VSUS) werden über eine Charge Pump auch von diesem Regler erzeugt. Da sollten keine 19V anliegen. Zumal, wenn da der 5V Schaltregler nicht aktiv ist.


Es könnte also durchaus der Regler defekt sein.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Harald« (19. April 2020, 13:39)


EDV-Dompteur

Administrator

Beiträge: 1 566

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

46

Sonntag, 19. April 2020, 23:48

Und dachte bis dato, das Ihr wo dies (Hauptberuflich?) macht evtl. einen Zugang zu den Herstellern habt.
Denn WILL ich nichtmal haben!
Geheimhaltungsvereinbarung unterschreiben; sich zu drakonischen Strafen verpflichten, wenn man dagegen verstößt; blah.


bin schon länger der Meinung dass es eine Pflicht geben sollte nach gewisser Zeit dinge offen zu legen.
Ich bin sogar der Meinung, dass die Hersteller verpflichtet sein sollten (und es von sich aus tun sollten), Schaltpläne und BIOS-Files etc. sofort zugänglich zu machen, sobald sie ein Gerät auf den Markt birngen!
Wenn ich ein Gerät für einen Kunden entwickle, dann liefere ich solche Sachen IMMER mit.
Ich würde mich in Grund und Boden schämen, das nicht zu tun!


Habe seit Jahren eine defekte Werkstatt Maschine stehen und davon gut 10-20 ROM dumps die alle unterschiedlich sind... Nun fehlt mir ausgerechnet die entscheidente Firmware das, dass Gerät wieder laufen würden und ich weiß nicht ob ich aus den Dumps was rekonstruieren könnte.
Was macht die Maschine denn Abgefahrenes?
Manchmal hilft es, eine (selbst noch so komplex wirkende) Steuerung ganz mutig einfach raus zu werfen und dafür eine selbstgestrickte Lösung einzusetzen, siehe mein Waschcenter-Thread:
https://www.edv-dompteur.de/forum/index.…read&postID=620


Mein Bruder nutzt seit Jahren Evernote.
Ich nutze Microsofts OneNote.
Das ist praktisch die gleiche Liga, beide haben individuelle Vorteile und Nachteile. Für mich überwogen bei OneNote die Vorteile.


Würdest du mich kurz erhellen, um was geht es dabei? Evtl. ein Link?
Du hast Zugriff darauf. Einfach auf der Startseite ins Suchfeld "Testimedes" eingeben.
Es gibt noch eine versteckte Tafelrunde, wo wir das Thema noch tiefer behandeln, aber wer da rein will, der muss Männchen machen.


Ganz merkwürdig finde ich die Werte direkt neben dem TPS rechts daneben befindet sich ich glaube ein Kerko bei dem Funktionierenden Board sind dort von links 5,1V und rechts 10,8V und bei dem Defekten Board kommt von links garnichts und rechts 1V.
Siehe Haralds Posting.
Messe bei den Schaltwandlern einfach an den Spulen, dann kann es keine Verwechslung geben.
Ein Multimeter funktioniert immer auf derjenigen Spulenseite, die zum Kerko führt.
Ob das Multimeter auch auf der anderen (geschalteten) Spulenseite sinnvolle Werte anzeigt, kann man nicht pauschal sagen. Hängt von der Konstruktion des Multimeters ab; manche können da völlig spinnen.

Ein billiges Oszi würde Dich diesbezüglich von jedem Zweifel befreien. Es sollte, damit man froh damit wird, aber eine mindestens(!) dreifach höhere Samplingrate haben, als die am Schaltwandler zu erwartende Schaltfrequenz.
Ein Megasample und aufwärts ist schon OK. Je doller aufwärts, umso besser. Da kriegt man schon für 'nen Hunni was.
Die 20,- EUR Oszis, mit ihren vielleicht 100kHz Bandbreite, sind echt etwas mau. Mit denen kommt man nur dann klar, wenn man weiß wie deren lustige Anzeigewerte zu interpretieren sind.

Wenn Geld keine Rolex spielt, und so 400,- bis 500,- Tacken drin sind, dann kriegt man richtig gute Geräte.
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte möglichst öffentlich im Forum stellen! -
Telefonische Reparaturtipps sind ab sofort kostenpflichtig, siehe hier:
https://www.edv-dompteur.de/forum/index.…ad&threadID=504

47

Mittwoch, 22. April 2020, 00:22

So jetzt ist das Geheimnis ohne jeden Zweifel gelüftet. Ihr hattet von Anfang an Recht. Den TPS habe ich gewechselt ohne Erfolg es sind immer noch die selben Probleme. Um alle Zweifel zu beseitigen habe ich es tatsächlich ohne Probleme geschafft den EC auszulöten und habe auch die 3,3V ohne EC messen können. Somit ist der EC hinüber. Einen neuen EC werde ich vermutlich nicht mehr drauf löten, da ich das Teil ja vorher flashen muss und mehr Equipment bräuchte. Da ich das nicht Beruflich mache wäre die Investition nicht wirklich sinnvoll.

Naja es ist wie es ist. Vielen herzlichen Dank an alle die hier fleißig mitgewirkt haben !!!