Sie sind nicht angemeldet.

1

Samstag, 1. Mai 2021, 19:21

Dell XPS 15 9560 - Flüssigkeitsschaden / Lässt sich nicht einschalten

Moin zusammen,

ich wollte euch heute Mal von diesem Gerät erzählen, dass ich vorgestern auf meinem Tisch hatte.

Vorgeschichte:

Es gab einen Flüssigkeitsschaden, es musste zunächst jedoch nur die Tastatur getauscht werden. Denn das Gerät lief nach Aussagen des Vorbesitzers noch monatelang weiter.

Fehlerbild:

Nach Einstecken des Adapters blitzt die Power-LED kurz auf. Danach kein Mucks mehr. Adapter-LED leuchtet stetig, was wiederum impliziert, dass kein Kurzschluss auf der Main-Power-Rail vorliegt.

Diagnose:

Nach dem Öffnen des Geräts und Ausbau des Motherboards offenbarten sich mehr oder weniger drei Bereiche, welche Flüssigkeit ausgesetzt waren. Betroffenen waren u.a. die Mosfets für Batterieladung, der EC und auch der Ladecontroller. Das erste was auffiel war, dass die 19V dennoch den Shunt erreichen, daher wurde das Augenmerk vorerst auf den 3V/5V-Controller gelegt.
Lediglich der 3.3V LDO erhielt seine korrekte Spannung. Der 5V LDO lief nur mit 4V und die Always-Spannungen waren so gut wie nicht existen, jedoch kein Kurzschluss feststellbar. Die Enables waren ebenfalls vorhanden. Dennoch war der erste Gedanke: Defekter 3V/5V Controller. Überprüfung des ICs hat nichts ergeben, außer dass nur 4V an VIN ankommen.

Ich habe dann das gesamte Board gereinigt und in den entsprechenden Bereichen einen Reflow durchgeführt. Leider war dIe einzige Veränderung, das an VIN nur noch zwischen 3V und 4V zu messen sind auch die Enable-Spannung deutlich abgesackt ist. Der 3V/5V-Controller war von nun an komplett funktionsunfähig.

Nach Studium des Schaltplans war klar, dass es sich hier um ein NVDC Design handelt, sprich die erzeugte Spannung an der Batterie-Spule ist gleichzeitig die "Main-Power-Rail" und die Spannung dort liegt bei viel zu niedrigen 4V.

Nun habe ich den Ladecontroller intensiv inspiziert und landete schließlich bei PR307, welcher offenbar defekt war. Der Innen-Widerstand war deutlich zu hoch mindestens im zweistelligen Bereich, statt 2.2Ohm) und dementsprechend passten die Spannungen auf beiden Seiten auch nicht (Ich meine auf der Controller-Seite ca. 5V und auf der gegenüberliegenden Seite fast nichts gemessen zu haben).

Mit der Entscheidung den Widerstand auszutauschen habe ich ein glückliches Händchen bewiesen, denn das Gerät konnte sofort gestartet werden.

Ich hatte bei der darauffolgenden Installation des Betriebssystems noch Probleme mit Bluescreens (diverse Fehlercodes), welche nach dem neu Einsetzten der RAM-Module glücklicherweise nicht mehr auftraten. Das Gerät bekommt noch ein neues Panel spendiert (hat leider an mehreren Stellen Flächen mit toten Pixeln) und dann darf es wieder weiter ziehen.

Versteckter Text Versteckter Text

Dieser Text wurde vom Autor versteckt.


Viele Grüße aus dem Wangerland und einen entspannten 1. Mai!


Edit von EDV-Dompteur: Den Link in die Hide-Box verfrachtet, wegen Copyright und so ...

EDV-Dompteur

Administrator

Beiträge: 1 954

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

2

Samstag, 1. Mai 2021, 20:00

Nach Studium des Schaltplans war klar, dass es sich hier um ein NVDC Design handelt, sprich die erzeugte Spannung an der Batterie-Spule ist gleichzeitig die "Main-Power-Rail"
Uff, den Begriff "NVDC" kannte ich noch gar nicht!?!
Auch das beschriebene Schaltungsprinzip habe ich nicht auf dem Schirm. Ich würde ja gerne mal den Plan sehen.


Nun habe ich den Ladecontroller intensiv inspiziert und landete schließlich bei PR307, welcher offenbar defekt war. Der Innen-Widerstand war deutlich zu hoch mindestens im zweistelligen Bereich, statt 2.2Ohm) und dementsprechend passten die Spannungen auf beiden Seiten auch nicht (Ich meine auf der Controller-Seite ca. 5V und auf der gegenüberliegenden Seite fast nichts gemessen zu haben).
Klaro, der Widerstand gehört zur Bootstrap-Schaltung, die das Gate des Upper-MOSFETs ansteuert. Ohne dem Widerstand wird die Gatespannung keine ausrechende Höhe erreichen, um satt durchzusteuern. Denn im durchgesteuerten Zustand liegen ja 19V am Source des Upper-MOSFETs und die Gatespannung muss um ca. 6V höher sein.

Ohne dem Widerstand würgt sich der MOSFET sozusagen selbst ab, wenn er am Gate angesteuert wird, denn sobald er beginnt, durchzusteuern, steigt die Spannung am Source, was eine gleichermaßen mitsteigende Gatespannung erfordert.

Beim Low-Side-MOSFET hat man solche Probleme nicht, weil Source dort auf Masse liegt, dort kann die Spannung nicht steigen, beim Durchsteuern.
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte öffentlich im Forum stellen, nicht telefonisch! -

3

Samstag, 1. Mai 2021, 20:12

Kein Problem,

habe ich soeben in den Bilder-Ordner mit rein gepackt. Lass dich von der Board-Nummer nicht irritieren. Die beiden Boards sind identisch. Wie du feststellen wirst, wird B+ direkt an der Batterie-Spulle erzeugt.

Viele Grüße

PS: Schön dass ich dir auch noch was neues zeigen kann. :)

EDV-Dompteur

Administrator

Beiträge: 1 954

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

4

Montag, 3. Mai 2021, 15:47

habe ich soeben in den Bilder-Ordner mit rein gepackt.
Den Link habe ich dann besser mal versteckt ...
Bilder allein wären ja problemlos gewesen, aber auf Pläne kann hier nicht verlinkt werden, um Ärger mit den Rechteinhabern zu vermeiden.


Was die Schaltungstechnik betrifft:
Da musste ich ganz schön schlucken! Da muss mein Schnellkurs mal ein Update kriegen, dieses Prinzip kannte ich noch nicht. Es erschloss sich mir sogar erst, nachdem ich nach dem Datenblatt dieses Chips suchte (leider fand ich nur ein verkürztes, sowie ein ähnliches, aber das Prinzip wurde mir dann klar).

Es ist schon ungewohnt ...
Aber tatsächlich wundere ich mich schon jahrelang, warum das nicht generell genau so gemacht wird.
Wo die einzelnen Vor- und Nachteile dieser Schaltungstechnik liegen, wird wahrscheinlich ein Thema für eine Diplomarbeit sein, aber die grundsätzliche Logik, alle Verbraucher an den Akku zu hängen und nicht mehr so relativ hart ans Netzteil zu koppel (nur durch die typischen Eingangs-MOSFETs getrennt), leuchtet mir intuitiv sofort als sinnvoll ein.


PS: Schön dass ich dir auch noch was neues zeigen kann. :)
Oh, Du bist so bescheiden und zerrst mich in gar zu helles Licht! :207:
Tatsächlich bist Du absolut auf dem Level, mir neue Dinge zeigen zu können! :211:
Auch von so einigen anderen Usern habe ich schon allerhand gute Inputs bekommen.
Das ist ja gerade das Prinzip eines Forums; wir alle lernen hier voneinander und wachsen dabei. Niemand wird jemals ganz ausgelernt haben.
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte öffentlich im Forum stellen, nicht telefonisch! -

Zur Zeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher