Sie sind nicht angemeldet.

1

Mittwoch, 18. August 2021, 16:37

Mein Thinkpad X61 ist tot!

Hallo Leute,
mein X61 ist tot! Kein Mucks, keine LED, weder mit Netzgerät noch mit Akku.
Ich habe das Problem schon im Thinkpadforum gepostet (https://thinkpad-forum.de/threads/230288…ein-X61-ist-tot ). Dort bekam ich auch schon einige Tipps und habe z.B. die Sicherungen überprüft - die haben alle Durchgang.
Jetrzt habe ich hier den Threat: https://www.edv-dompteur.de/forum/index.…ad&threadID=302 gefunden und würde gerne die besagten MOSFETS überprüfen - habe aber keine Ahnung wo ich die suchen muss.
Im Thinkwiki gibt es ein Foto mit dem Mainboard und den Sicherungen (https://thinkwiki.de/X61_Sicherungen )- vielleicht habt ihr eine Idee?

2

Donnerstag, 19. August 2021, 22:42

Hallo erikafuchs,

das mit den Sicherungen ist zwar eine nette Idee, aber nicht der weg wie grundlegend eine Fehlersuche auf einem Laptop Motherboard durchgeführt wird welches sich komplett tot stellt. Wir fangen wie du ja jetzt auch schon richtig erkannt hast immer beim DCIN-Circuit bzw. den DCIN-Mosfets an. Ich würde vermuten, dass J6 der Connector für die Ladebuchse, der Mosfet oberhalb von F15 der erste Mosfets und der Mosfet oben links gesehen von F4 der zweite Mosfet ist?

Das lässt sich mit einer Durchgangsprüfung, natürlich stromlos, einfach überprüfen. Interessant sind aber vor allem die Spannungen. Also, was kommt an am ersten Mosfet, am zweiten Mosfets und schließlich an R32 den Current-Sense-Resistor an?

Es wäre auch möglich, dass dein Netzteil schlicht und ergreifend defekt ist. Dein Bericht in dem Forum würde das zumindest nicht widerlegen. Warum war es dir nicht möglich die Spannung des Netzteils zu prüfen?

Viele Grüße!

PS: Ich bin mir sicher hier wird es von Seiten des EDV-Dompteurs eine Anpassung des Benutzernamens geben, da der Registrierungsdialog den ersten Buchstaben in "groß" vorsieht. :)
PPS: Es wäre super, wenn du die ganze Vorgeschichte hier nochmal einfügen würdest, da es wirklich mühsam werden könnte sich durch mehrere Threads zu wühlen.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Razzenhead« (19. August 2021, 23:53)


3

Freitag, 20. August 2021, 20:19

Vielen Dank für deine Antwort.
Das mit dem Großbuchstaben muss ich übersehen haben, steht das im Kleingedruckten?
Die Vorgeschichte ist nicht so umfangreich. Ich habe das Gerät zerlegt, da der Lüfter schnarrt (da habe ich übrigens noch keine Ursache gefunden). Zerlegt wollte ich das Gerät anwerfen und es machte weder einen Mucks, noch leuchtet eine LED. Ich habe das mit drie Netzgeräten versucht, keine Änderung. Zwischenzeitlich kenne ich auch die Belegung des Kabels mit dem der Netzteilsteckers mit dem Mainboard verbunden ist - da leigen 20 Volt an. Dann bekam ich im Thinkpadforum den einen oder anderen Tip, es läuft drauf raus, dass irgendwo die Stromversorgung unterbrochen ist. Die Sicherungen habe ich durchgemessen und dann hier den prima Artikel mit den MOSFets gefunden. Als Laie finde ich die nicht. Nach deinen Tipps werde ich am Wochenende mal auf die Suche gehen.

Zitat

Das lässt sich mit einer Durchgangsprüfung, natürlich stromlos, einfach überprüfen.
Wie mache ich das? Welche Beinchen?
Ist es dabei nicht einfacher das Netzgerät anzuschließen und die Spannung an den MOSFETS zu messen?
Grüße Pit

4

Freitag, 20. August 2021, 21:15

Wie mache ich das? Welche Beinchen?
Ist es dabei nicht einfacher das Netzgerät anzuschließen und die Spannung an den MOSFETS zu messen?


Dazu muss man natürlich wissen, wie so ein Mosfet aufgebaut ist, namlich bestehend Source, Drain und Gate. Bei einem Mosfet mit 8 Pins kann man eigentlich nie etwas falsch machen wenn man die Prufspitzen an einem der beiden mittleren Pins anlegt.
Es ist halt entscheidet das bei der Durchgangsprüfung nicht versehentlich ein Gate-Pin ins Spiel kommt, das ist i.d.R. Pin 4 bei einem Package wie bei dir auf dem Board vorhanden.

Die Idee mit Spannung messen ist nicht so verkehrt, kannst du auch gerne so machen, müsste im Bedarfsfall halt nochmal genau geschaut werden, ob alles so verbunden ist, wie vermutet. Das kann man nämlich so nicht prüfen, höchstens mutmaßen und da ist für unsere Zwecke zu wenig. :)

Viele Grüße

5

Freitag, 20. August 2021, 22:28

Es ist halt entscheidet das bei der Durchgangsprüfung nicht versehentlich ein Gate-Pin ins Spiel kommt, das ist i.d.R. Pin 4 bei einem Package wie bei dir auf dem Board vorhanden.

Pardon .... für Laien - Gate-Pin? Pin4? Package?

6

Samstag, 21. August 2021, 00:51

Okay, wir benötigen wohl ein Beispiel.

Das Package bezeichnet die Bauweise des ICs, in deinem Fall ist das sowas wie SOIC-8 (es gibt viele weitere Packages für diverse SMD).
Man muss halt klar erkennen, das Manche Pins miteinander verbunden sind, andere wiederum nicht. Anhand des mutmaßlich ersten DCIN-Mosfet gilt in deinem Fall:

Grün: Source
Rot: Drain
Blau: Gate

Es ist auf dem PCB deutlich zu erkennen, dass Gate, also Pin 4 keine Verbindung zum Rest hat, während Source aus drei Pins besteht und Drain sogar aus vier Pins, wenn man so will.
Gezählt wird üblicherweise (und bis auf wenige Ausnahmen) vom Markierungs-"Dot" bzw einer speziellen Markierung auf dem PCB GEGEN den Uhrzeigersinn.

IMG_20210821_004351.jpg

PS: Da ich den Hersteller des Mosfets (Vishay) bereits vom sehen identifizieren konnte, hänge ich Mal das Datenblatt mit dran.
»Razzenhead« hat folgende Datei angehängt:
  • si4435bd.pdf (88,14 kB - 163 mal heruntergeladen - zuletzt: 21. Oktober 2021, 01:59)

7

Sonntag, 22. August 2021, 20:11

Uiii, da lerne ich aber wieder was dazu. Also, die beiden Teile liegen sich auf dem Mainboard gegenüber und sind direkt an dem Stecker der Ladebuchse.

Habe ich das jetzt richtig verstanden: Ich hänge das Board an das Netzgerät und dann müsste an den Beinchen 5-8 knapp 20Volt anliegen? Und wenn nicht, müsste ich Beinchen 4 überprüfen. Es ist ein "P-Kanal" (habe ich aus der Anleitung von EDV_Dompteur erarbeitet) und müsste gegen Masse dann ebenfalls etwa 20 Volt anzeigen. Falls ersteres nein und zweites ja, dann MOSFET defekt?

8

Sonntag, 22. August 2021, 20:44

Habe ich das jetzt richtig verstanden: Ich hänge das Board an das Netzgerät und dann müsste an den Beinchen 5-8 knapp 20Volt anliegen? Und wenn nicht, müsste ich Beinchen 4 überprüfen.


Jaein,

also ja... 20Volt sollten an 5-8 (Drain) anliegen, dann wissen wir, dass der erste Mosfet durchgeschaltet hat. Die Voraussetzung dafür ist, dass an 1-3 (Source) ebenfalls 20V Anliegen, die ja laut meiner Theorie vom Connector kommen, und Gate entsprechend durchschaltet (mehr dazu im nächsten Absatz).
Beim zweiten Mosfet wird es genau anders herum sein. Drain des ersten Mosfets trifft auf Drain des zweiten Mosfets (Beweisführung mittels Durchgangsprüfung). Das dient bspw. dazu, dass das Netzteil nicht beschädigt wird, wenn es ungewollte Spannungsflüsse auf dem Board gibt.
Der zweite Mosfet sollte ebenfalls die 20V via Gate zu Source durchschalten und von dort aus verteilen sich die 20V dann über das gesamte Board. Daher ist der "Shunt" oder im englischen auch "Current Sense Resistor' genannt (oberhalb des zweiten Mosfets zu sehen), immer ein guter Start-Punkt um diese wichtigste Spannung auf dem Motherboard zu überprüfen.

Damit ein P-Channel Mosfet 20V durchschaltet, muss die Gate-Spannung niedriger liegen, vllt so bei 15 - 16V. Im Gegensatz zu einem N-Channel Mosfet, bei dem Sie höher liegen muss, ich denke so 24 - 25V

Falls erster oder zweiter Mosfet nicht durchschalten müssen wir erstmal nach dem Warum schauen. Es ist nicht immer der Mosfet schuld.^^

Viele Grüße

PS: Alle Angaben ohne Gewähr, da für mich noch nicht vollständig geklärt ist, ob diese beiden wirklich die DCIN-Mosfets sind. Der "Beep" Test ist für sowas immer Recht hilfreich.

9

Sonntag, 22. August 2021, 22:40

Der "Beep" Test ist für sowas immer Recht hilfreich.

???

Zitat

Das lässt sich mit einer Durchgangsprüfung, natürlich stromlos, einfach überprüfen.
Hat das damit zu tun? Kann man das mit einem Ohmmeter (Pardon, mit einer Widerstandmessung überprüfen) testen? Aber wenn ich das richtig verstanden habe, ist doch dieses Teil nur durchgeschaltet, wenn am Gain eine Spannung anliegt und wenn das das Teil widerum defekt ist, dann ist auch kein Durchgang obwohl eine Sapnnung anliegt - oder wie (pardon, da bin ich Laie)? Das heißt, ohne anliegende Spannung ist da so oder so kein Durchgang?

10

Sonntag, 22. August 2021, 22:52

Nicht so kompliziert denken. Wir wollen ja nur wissen, ob der Connector wo das Netzteil rein gesteckt wird mit Source des ersten Mosfets und ob Drain des ersten Mosfets mit Drain des zweiten Mosfets verbunden ist. Die Mosfets selbst kann man auch testen aber das steht jetzt noch nicht zur Disposition. Es geht hier um nichts anderes als die Beweisführung das wir Teile des DCIN-Circuit korrekt aufgeschlüsselt haben.
Wir arbeiten uns mit einer systematischen Vorgehensweise in Richtung des Problems, okay?

Natürlich geht das auch im Ohm-Mode aber auch im Diode-Mode (viele MM sind hier mit einem deutlich hörbaren "Beeeep" ausgestattet welcher bei einem niedrigen Wert ertönt. Das meinte ich vorhin.^^

11

Sonntag, 22. August 2021, 23:32

Also nochmal für Blöde: Ich soll erstmal feststellen, ob an 1,2,3 vom ersten MOSFET Spannung anliegt? Und der Drain (Ausgang?) des ersten liegt am Drain (Ausgang) des zweiten? Und wenn die hintereinandergeschaltet sind: Wie kann man wissen, welches der erste und welches der zweite ist? Was ist ein/e MM (Multimeter?) und was macht Beep? Für "Diode Mode" benötige ich vermutlich ein Meßgerät zum Überprüfen von Dioden?

Und nochmals:

Zitat

Das lässt sich mit einer Durchgangsprüfung, natürlich stromlos, einfach überprüfen.
... ich hatte gedacht, mit "natürlich stromlos" sollte ich erstmals den Widerstand überprüfen und kein Netzgerät anschließen. Bitte bedenke: Ich bin kein Elektroniker und kenne nur den Unterschied zwischen Stromstärke, Spannung und Widerstand.

12

Sonntag, 22. August 2021, 23:37

Uff,

Ich nehme an ich gebe hier zu viele Informationen/Hinweise auf einmal weswegen es zu Irritationen kommt.

ich würde sagen wir drücken jetzt erstmal auf den "Reset"-Button in unserem Kopf und dann machst du die Spannungsprüfung am mutmaßlich ersten Mosfet, Pins 1-3 (Source).

Und ab dann arbeiten wir uns Stück für Stück vor.

Das Konstrukt sollte nachher so aussehen:

Connector --> Source 1. Mosfet --> Drain 1. Mosfet --> Drain 2. Mosfet --> Source 2. Mosfet --> Current Sense Resistor.

Und ja, wenn einem diese Logik bewusst wird, dann lässt sich das definitiv mittels Multimeter nachweisen.

13

Montag, 23. August 2021, 00:06

Vielen Dank für die Nachsicht! Da geht es morgen ... nun ja später heute (es ist kurz nach Mitternacht) weiter.
So long

14

Montag, 23. August 2021, 21:27

Vielen Dank für die Nachsicht! Da geht es morgen ... nun ja später heute (es ist kurz nach Mitternacht) weiter.

So long
Also: Der MOSFET bei F4 hat an allen Beinchen etwa 20Volt und der auf der Rückseite über F15 hat nur rechts 20Volt, links nicht. Ist der also defekt?

15

Dienstag, 24. August 2021, 08:34

Wir kommen dem Fehler offenbar schneller auf die Schliche als angenommen.
20V an allen Pins bedeutet, das auch GATE beider Mosfets 20V Spannung führt (ist das so?) was wiederum bedeutet, einer der Mosfets intern kurzgeschlossen ist.

Mach Mal bitte folgendes:

Gerät stromlos machen und Multimeter auf Widerstandsmessung (auf 200 einstellen wenn möglich oder Auto-Range) einstellen. Dann machst du an beiden Mosfets jeweils drei Messungen.

Von SOURCE nach DRAIN
Von SOURCE nach GATE
Von DRAIN nach GATE

Auf diese Weise können wir beweisen ob tatsächlich ein interner Kurzschluss vorliegt oder der Fehler doch woanders liegt.

16

Dienstag, 24. August 2021, 15:23

Bei allen sechs Messungen wird kein Durchgang angezeigt - außer bei Source -> Gate auf der Vorderseite (bei F4). Ich hoffe, ich habe die richtigen Beinchen auch richtig getroffen.
Aber zum Verständnis: Was machen die beiden Teile eigentlich? Wenn Spannung anleigt, dann schalten sie durch und wenn nicht nicht. Sollen die eine Verpolung verhindern? Und zweitens muss man bei der Widerstandsmessung nicht die Polung beachten, da der Strom nur in einer Richtung fließen kann? OK Ich habe mal die Schnellanleitung gelesen und da ist die Funktion erklärt - zumindest habe ich verstanden, dass die Teile sperren wenn was nicht stimmt.

17

Dienstag, 24. August 2021, 15:35

Also ich bin ja sozusagen auch nur Laie, aber da wir nur wissen wollen ob es internen Widerstand gibt oder nicht, ist das in diesem Fall unerheblich.

Also, herzlichen Glückwunsch. Der Mosfet nahe "F4" ist intern zwischen Source und Gate kurzgeschlossen. Das darf er nicht, weil er sonst nicht mehr funktioniert.
Ob du die richtigen Beinchen getroffen hast, könntest du mir ja zeigen, in dem du deine Messung Mal bebilderst. Ansonsten ist es auf dem PCB wie ja schon erwähnt mehr oder weniger klar ersichtlich was zusammen gehört und was nicht. Der Gate-Pin ist immer ein Einzelgänger^^
Also, wenn das alles so stimmt, muss der Mosfet ausgetauscht werden.
Gegenprobe könnte auch gemacht werden, indem du den Mosfet einfach Mal auslötest und schaust ob der Kurzschluss zwischen Source und Gate dann weg ist.

Was diese Mosfets im Detail machen oder verhindern, dafür bin ich der falsche Ansprechpartner, in den Datenblättern ist für mich auch noch vieles "japanisch", aber u.a. sollen die verhindern das der Strom ins Netzteil zurückfließt. Da kann bestimmt der Stefan mehr zu sagen.

18

Dienstag, 24. August 2021, 16:43

jetzt habe ich mir eine Lupe gesucht (das Pünktchen bei Gate ist kaum zu sehen) und die Anleitung gelesen (größtenteils) und genauer gemessen:
Der MOSFET bei F4 hat an Source und Drain jeweils etwa 20Volt und an gate etwa 19Volt. Der Unterschied zwischen 20Volt und 19Volt scheint ja wichtig zu sein. Das soll ja wohl so sein. Der bei F16 hat bei Source 20Volt, bei Gate 19 Volt und bei Drain nur etwa 1V. Soll ich da einfach mal Source und Drain überbrücken?

19

Dienstag, 24. August 2021, 19:33

Die Wahrheit ist, wir kommen so nicht weiter.

Nach deinen neuesten Messungen ist der erste Mosfet der zweite und der Zweite Mosfet der erste, was irgendwie nicht stimmen kann, da der zweite auf jeden Fall Kontinuität mit dem Shunt haben muss.

Einen Kurzschluss zwischen Source und Gate kann auch nicht vorliegen, sonst würde keiner der Mosfets durchschalten, aber einer tut es ja auf jeden Fall.

Solange du mir jedesmal andere Ergebnisse vorlegst, drehen wir uns natürlich im Kreis

Also bleibt uns jetzt am Ende doch nichts anderes übrig als mittels Kontinuitätsprüfung alles nachzuverfolgen, vom DCIN-Connector bis zum Shunt.

Oder Mal ganz blöd gefragt: Hast du 19V am Shunt anliegen? Dann können wir uns den Bereich jetzt sparen und mit dem nächsten Circuit weiter machen.

20

Mittwoch, 25. August 2021, 00:26

Ich kann das nachvollziehen, ich bin (war) Lehrer. Wir Schüler verstehen oft die einfachsten Sachen nicht, obwohl sie doch ganz einfach sind und schon oft genug erklärt wurden. Tut mir echt Leid und ich bewundere deine Geduld.
Probieren wir es noch mal:

Zitat

Connector --> Source 1. Mosfet --> Drain 1. Mosfet --> Drain 2.
Mosfet --> Source 2. Mosfet --> Current Sense Resistor.
Das muss ich so verstehen, dass der Strom in dieser Reihenfolge durchgeschaltet wird und nach meiner Messung das so nicht sein kann, weil beim zweiten MOSFET bei Drain 20V anliegen müsste und nicht bei Source? Ich habe gerade (00:14 Uhr) das nochmals überprüft: (Die vier parallelen Beinchen sind Drain und die drei sind Source) dann kann es ja eigentlich nicht sein, dass beide Source Spannung haben aber nur eine Drain - ist aber so - ich habe jetzt dreimal nachgemessen. Das ist doch jetzt auch kein Unterschied was Nr1 und Nr2 ist, oder sehe ich das verkehrt? Wenn du mir jetzt erklären kannst, was "Shunt" und "Kontinuität mit dem Shunt" bedeutet, kann ich ja nochmals darüber hirnen, was ich falsch gemacht habe. (Falsche MOSFET?)

21

Mittwoch, 25. August 2021, 09:07

Auch von mir ein Sorry, dass ich ein bisschen direkt geworden bin.

Ich verstehe aber das grundsätzliche Problem. So lange der Zusammenhang nicht klar ist, ist es schwer sinnvolle Messungen zu machen.

Versuchen wir es nochmal. Das Board bitte einmal komplett stromlos machen. Stelle Mal das Multimeter auf Widerstandsmessung ( Ohm ), Falls die Range der Widerstandsmessung einstellbar ist, bitte auf 200 einstellen (Ich kenne dein Multimeter nicht.)

Du hast das in Summe mittlerweile ganz gut erfasst. Wir versuchen jetzt nachzubilden was du im Beitrag vorher nochmal von mir zitiert hast, also fangen wir bei "Plus" am Connector an.

Erste Prüfsonde auf den Connector, mit der zweiten Prüfsonde gehst du an jeden Mosfet (Source und Drain) in der Nähe (auch auf der gegenüberliegenden Seite des Boards nachschauen), bis du einen Wert nahe 0 (Kontinuität) angezeigt bekommst.

So kriegen wir raus, welches der erste Mosfet ist. Sobald du den gefunden hast, erkläre ich, wie es weiter geht. Sonst wird es wieder zu viel.

Und nochmal zum "Shunt" oder auch "Current Sense Resistor". Das ist sozusagen der wichtigste Widerstand auf dem ganzen Board. Er ist der erste Widerstand auf dem die 19V/20V treffen sobald diese vom DCIN Circuit durchgeschaltet sind. Der Ladecontroller misst auch exakt an dieser Stelle den Strom und schaltet ggfs. ab.
Der Grund warum der Shunt/Current Resistor gerne als Referenz für die Hauptstromschiene genannt wird ist, weil er oftmals alleine durch seine Größe und Form leicht zu erkennen ist und man so sichere und schnelle Messungen machen kann.

Ich bin mir zu 99% sicher, dass das der "Shunt" auf deinem Board ist:

IMG_20210825_090551.jpg

Viele Grüße

22

Mittwoch, 25. August 2021, 10:27

Ich hoffe, ich habe das jetzt richtig verstanden. Zwischen DCIN und der Source des MOSFET bei F15 ist Durchgang und damit ist das MOSFET1
Ich bin am Samstag zu einem Treffen der Thinkpad Freunde eingeladen, da kommt auch eine vielgelobte Bastelkoryphäe mit Lötkolben. Ich bekomme diese SIM Bauteile nicht rein und raus (Bei meinen Lötversuchen habe ich bisher alles verbrutzelt) - macht es Sinn mich schon mal nach zwei MOSFETs umzutun und obige Typen dafür zu nehmen?

23

Mittwoch, 25. August 2021, 10:37

Ich bekomme diese SIM Bauteile nicht rein und raus (Bei meinen Lötversuchen habe ich bisher alles verbrutzelt) - macht es Sinn mich schon mal nach zwei MOSFETs umzutun und obige Typen dafür zu nehmen?


Dafür ist es ehrlich gesagt zu früh. Wir wissen noch überhaupt gar nicht was das Problem ist, umso wichtiger, dass wir jetzt zügig Voran kommen.

Also ich bestätige, der Mosfet bei F15 ist unsere Nummer 1. So habe ich mir das von Anfang an gedacht.

Zurück zur Theorie: Der erste Mosfet schaltet die 20V von Source zu Drain durch und von dort aus geht's weiter zum zweiten Mosfet. Also machen wir jetzt folgendes.

Eine Prüfsonde auf DRAIN des ersten Mosfet und mit der zweiten Prufsonde tastest du wieder jeden Mosfet in der Umgebung ab (SOURCE und DRAIN) bis du einen gefunden hast der uns Kontinuität anzeigt.

So hätten wir es von Anfang an machen sollen^^

24

Mittwoch, 25. August 2021, 15:42

Ich habe mir ja jetzt wirklich Mühe gegeben - ich finde keinen! Und der bei F4 und der bei F15 sitzen ziemlich parrallel auf Vorder - und Rückseite der Platine. In der Nähe von dem MOSFET1 sitzen noch 4 - ohen Verbindung auf der Rückseite nur noch einer. Alle anderen sind weiter weg.

25

Mittwoch, 25. August 2021, 15:55

Das ist wahrscheinlich auch eine Erklärung dafür, dass ein wenig Verwirrung herrschte.

Also was ist hier los... du hast auch ganz sicher von DRAIN des 1. Mosfet gemessen? Der dicke Connector mit dem gelben Tape auf der linken Seite ist doch der, bei dem nachher das Netzteil angeschlossen wird, oder?

Rein von der Logik her muss es einfach der Nahe F4 sein, auch weil direkt darüber der Shunt sitzt zu dem er ganz klar eine Verbindung hat. Da brauche ich auch kein Multimeter dazu.

Gut, wir beenden das jetzt Mal kurz und du misst jetzt einfach Mal die Spannung am Shunt/Current Sense Resistor.

Ich habe bereits versucht einen Schaltplan aufzutreiben. Leider bisher vergeblich. Das würde alles enorm vereinfachen.

Zur Zeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Verwendete Tags

strom, Thinkpad, X61