Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: EDV-Dompteur/Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Dienstag, 2. März 2021, 15:21

(noch ein) Acer Nitro 515-54. Feuchtigkeit. Keine Ladung

Moin Leute,

habe heute erneut ein Acer Nitro bekommen. Dieses mal ohne Funktion nach Feuchtigkeit. Fehlerstelle lokalisiert und den PUB1 getauscht (Kurzschluss). Gerät läuft wieder, es lädt jedoch nicht. Am Pin vom Batt Conn liegen mit Netzteil nur 3,5V an. PQB1 und PQB13 haben an S jeweils nur 3,5V. AN D liegen die 20V an.

Ich habe leider keinen Plan wie diese Mosfets am Gate angesteuert werden (10V sollten es wohl sein um durchzuschalten?). Da wäre am PUB1 die Line BGATE und dann noch Phase für LX_CHG (hier sollten 17,4V anliegen).

Datasheet für den PUB1 gibt es bei Mouser (https://eu.mouser.com/datasheet/2/698/RE…216-1697158.pdf).

Die Schematic für das Mainboard gibt es hier (https://www.edv-dompteur.de/forum/index.…ad&threadID=728).

Wie genau kommt die Spannung für das Gate zustande bzw. wo wird das beeinflusst?

Hier die Schematic der Ladung


EDV-Dompteur

Administrator

Beiträge: 1 938

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

2

Dienstag, 2. März 2021, 15:38

Für das Laden des Akkus ist nicht PQB13 verantwortlich.
Sondern dieser MOSFET schaltet im Akkubetrieb die Spannung des geladenen Akkus auf die Systemrail.

Zum Laden sind die beiden MOSFETs PQB1 und PQB2 zuständig.
Und die funktionieren in Verbindung mit dem IC PUB1 und der Spule PLB1 und den Kapazitäten rechts vom Shunt PRB16 halt wie ein ganz normaler Buck-Schaltwandler. Also genauso, wie auch alle anderen Spannungen im Notebook erzeugt werden.
Der Schnellkurs behandelt das Thema ja (auch den Links folgen, an den entscheidenen Stellen).


Da Du am Akku nur 3,5V misst, sieht es danach aus, dass der Akku tiefentladen wurde und somit hinüber ist.


P.S.: Das verlinkte Datenblatt ist leider nur eine "Short-" Version.
Es wäre schön, die vollständige Version zur Verfügung zu haben.
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte öffentlich im Forum stellen, nicht telefonisch! -

3

Dienstag, 2. März 2021, 16:19

Konnte nur die kleine Version vom Datenblatt finden. Selbst auf der Herstellerseite gibt es nur die Short Version.

Habe hier noch einen zweiten Akku vom anderen Thread (PCH short) und da liegen auch nur 3,5V am Konnektor an.
Laut dem Schnellkurs müssen die beiden Mosfets durchsteuern wenn 19V anliegen. Am PQB1 liegen an S keine 19V an. Da liegen 0,6V an.
Da PQB1 nicht durchsteuert (an G liegen ~0,7V an) gehe ich davon aus, dass der PUB1 das Problem, da Pin 23 wohl 10V haben sollte, damit Mosfet 1 durchsteuert.

EDV-Dompteur

Administrator

Beiträge: 1 938

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

4

Dienstag, 2. März 2021, 17:22

Halt, da verdröselst Du eine Menge.

PQB1 und PQB2 sind NICHT die beiden Eingangs-MOSFETs, um die es in den ersten Postings des Schnellkurses geht.
Die Eingangs-MOSFETs, die auf Deinem Bild leider nicht zu sehen sind (sie wären ganz links oben, ein Stück aus dem Bild heraus) müssen bei angeschlossenem Netzteil tatsächlich permanent durchschalten. Da gestaltet sich das Messen sehr einfach.

Bei den für die Akkuladung zuständigen MOSFETs PQB1 und PQB2 hingegen, handelt es sich um getaktet angesteuerte MOSFETs. Da ist es mehr oder weniger Zufall, was ein Multimeter anzeigt. Bzw. es ist von dessen genauer Konstruktionsweise abhängig.
An solchen getakteten MOSFETs muss man mit dem Oszi messen, da hilft einem ein Multimeter nicht viel weiter.

Aus Deinen Worten wird mir klar, dass Du noch gar nicht verstanden hast, wie ein Schaltwandler eigentlich funktioniert.
Der Schnellkurs behandelt das Thema ab dem Posting Nr. 10. Dort allerdings zunächst bezogen auf die Schaltwandler für 5V und 3,3V. Die sind für Dich gerade uninteressant, dennoch ist das Prinzip auf den Schaltwandler für die Akkuladung übertragbar.

In Posting Nr. 11 des Schnellkurses verlinke ich auf weiterführende Informationen zu Schaltwandlern, die Du Dir ansehen solltest, um das Prinzip zu verstehen.
Dieses Grundprinzip kommt wirklich bei sämtlichen Schaltwandlern in jedem beliebigen Notebook immer wieder zum Einsatz. Und niemals ein anderes Prinzip.

Es können in Schaltwandlern zwar verschiedene Chiptypen verbaut sein, die im Detail hier und da so ihre speziellen Eigenschaften haben, aber das Grundprinzip ist immer gleich:
Die beiden MOSFETs vor der Spule werden in schneller Folge abwechselnd angesteuert und die Spule wirkt elektrisch so, wie eine "träge Masse" in der Mechanik. Sie sträubt sich gegen schnelle Stromänderungen, was auf die Spannung hinter der Spule stabilisierend wirkt. Und die Kapazitäten hinter der Spule stabilisieren auf ihre eigene Weise weiter, indem sie sich gegen schnelle Spannungsänderungen sträuben.
Im Resultat erhält man eine gegenüber der Eingangsspannung niedigere und ziemlich gut stabile Spannung.
Und der Clou dabei: Der verfügbare Strom erhöht sich!

Ja, hinter einem Schatwandler steht eine zwar niedrigere Spannung, aber dafür ein entsprechend höherer Strom zur Verfügung!
Ein weit höherer Strom, als das Netzteil herzugeben in der Lage ist!
Denn es gilt (unter Vernachlässigung von Wirkungsgradverlusten): Ausgangsleistung ist gleich der Eingangsleistung.
Formel:
P_out = P_in
und weiter:
P = U * I
(Leistung ist gleich Spannung mal Strom)

Wird bei gleicher Leistung die Spannung niedriger, so erhöht sich der Strom, damit die Gleichung weiterhin aufgeht.

Das hat Ähnlichkeit mit einem Hebel in der Mechanik, oder einem Getriebe.
Dort kann aus einem schnell laufenden, aber schwachen Motor ein hohes Drehmoment bei niedrigerer Drehzahl gewonnen werden.

Aber das wird im Schnellkurs, bzw. den dort verlinkten Informationen, ja alles hinreichend tief erklärt.


Wieder zu Deinem Fall:
Da auch Dein Ersatz-Akku nur 3,5V zu liefern scheint, wird es leider komplizierter ...
Damit ein Ladecontroller (hier PUB1) sich bequemt, einen Akku zu laden, müssen allerhand Bedingungen gegeben sein, die man normalerweise dem vollständigen Datenblatt entnimmt.
Und damit ein Notebook-Akku überhaupt Spannung liefert, muss er über den SMBus mit dem Mainboard kommunizieren. Denn im Akku steckt eine überraschend komplexe Elektronik, die bei vielen Akkus aus Sicherheitsgründen so konstruiert ist, dass der Akku erst dann Spannung liefert, wenn er sich per SMBus angesprochen fühlt.

Es ist leider durchaus tüftelig, die Ursachen herauszufinden, warum es klemmt, wenn es im Bereich des Akkus klemmt.
Man könnte z. B. per Oszi schauen, ob auf den Akku-Anschlüssen vom SMBus überhaupt ein Datenverkehr stattfindet.
Man könnte auch den Ladecontroller mal testweise dazu zwingen, aktiv zu werden - was aber das vollständige Datenblatt erfordert, sofern der simple Trick versagt, den ich in Posting Nr. 15 des Schnellkurses beschreibe (der funzt nämlich nicht immer).

Da Dir offenbar weder Oszi, noch das Datenblatt zur Verfügung steht, kannst Du momentan nicht viel mehr machen, als die MOSFETs PQB1 und PQB2 durchzumessen, oder im Zweifelsfall pauschal auszutauschen.
Es wäre z. B. denkbar, dass der untere MOSFET (PQB2) leakt, aber so wirklich eindeutig sieht es mir danach nicht aus.

Aber Du könntest PQB1 und PQB2 mal auslöten und dann schauen, ob am Akkuanschluss dann eine sinnvolle Spannung messbar ist.
Wenn ja, dann Akku heil und Kommunikation auf dem SMBus OK.
Dann sollte die Kiste per Akku laufen können (sofern noch genug Ladung vorhanden ist).
Das grenzt den Fehler schon mal deutlich ein.
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte öffentlich im Forum stellen, nicht telefonisch! -

5

Mittwoch, 3. März 2021, 13:18

Erstmal danke dir für diese ausführliche Erklärung. Den Schnellkurs habe ich, muß ich gestehen, nur leicht überflogen und bin dann auf die Sache mit den beiden Mosfets gestoßen (welche ich natürlich, wie du schon sagst, falsch interpretiert habe).

Aufgrund der aktuellen Situation (kein Plan und falsche Information und dank Kurzarbeit noch 1000 andere Sachen nebenher) ist das für mich alles ein wenig stressig. Ich bitte daher meine Unwissenheit zu entschuldigen. Ich hätte den Laptop auch nicht angenommen, wenn es nicht ein Bekannter wäre.

Jetzt zum Fall.

Ich hatte gestern Abend noch den PBQ 2 getauscht, aber das Ergebnis blieb das gleiche, keine Ladung. Danach habe ich noch einen Kondensator getauscht, welcher an einer Seite wegkorrodiert war und auf einmal konnte ich die Akkuspannung ablesen. In dem Fall dann 14,5V und das Gerät lief nun auch am Akku. Dieser hatte zwar nur 5%, aber es lief ohne Netzteil.

Danach nochmals den kompletten Bereich der Feuchtigkeit angeschaut und geputzt und da fiel auf, dass an 2 Punkten bereits Korrosion unter den Messpunkten war. Diese habe ich dann auf Durchgang geprüft und festgestellt, dass diese OL waren.
Alles gereinigt und die beiden Leitungen wieder verbunden und siehe da. Es lädt.

Danke aufjedenfall bis hier hin.

Eine Frage habe ich aber trotzdem. Wie genau sieht das aus, wenn du sagts PBQ1 und 2 raus und probieren ob es lädt? Einfach die beiden überbrücken, so wie du es im Schnellkurs beschrieben hast? Da ich kein Kurzschluss festgestellt habe, war das zumindest eine Vermutung, um überhaupt zu prüfen ob der Akku Spannung annimmt.

Ich werde deinen Text heute Abend nochmal in Ruhe lesen. Danke vielmals.

6

Mittwoch, 3. März 2021, 13:30

Generelle Vorgehensweise bei einem Flüssigkeitsschaden ist, alles zu reinigen bzw. nachzulöten bzw. auszutauschen, was verdächtig aussieht. Stefan würde wahrscheinlich das "Vollbad" in Säure, Lauge, Wasser und Isopropanol empfehlen. Spätestens wenn nichts anderes mehr hilft, ist das auch auf jeden Fall angebracht... :)

Eine Frage habe ich aber trotzdem. Wie genau sieht das aus, wenn du sagts PBQ1 und 2 raus und probieren ob es lädt? Einfach die beiden überbrücken, so wie du es im Schnellkurs beschrieben hast? Da ich kein Kurzschluss festgestellt habe, war das zumindest eine Vermutung, um überhaupt zu prüfen ob der Akku Spannung annimmt.


Durch das Auslöten der beiden Mosfets hättest du quasi überprüft ob,
a) die Ladespannung deine Akku-Spannung "herunter zieht" und
b) die reine Kommunikation zwischen Board und Akku grundsätzlich funktioniert.

Wahrscheinlich war das auch der Fall, denn zwei defekte Akkus wären schon seltsam gewesen. Ein großer Gegner bei einem Flüssigkeitsschaden ist halt Korrosion. Und genau so wird es auch bei dir gewesen sein.

Viele Grüße!

EDV-Dompteur

Administrator

Beiträge: 1 938

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

7

Mittwoch, 3. März 2021, 14:26

Danach nochmals den kompletten Bereich der Feuchtigkeit angeschaut und geputzt und da fiel auf, dass an 2 Punkten bereits Korrosion unter den Messpunkten war.
Na, die gründliche Reinigung und optische Kontrolle hätte aber definitiv an erster Stelle stattfinden müssen.
Dann die optisch auffälligen Schäden beseitigen und erst dann ein erster Funktionstest.
Angesichts Deines Vorstellungs-Postings hätte ich fest erwartet, dass Dir das klar sein muss, wenn Du doch schon seit acht Jahren Geräte reparierst!


Diese habe ich dann auf Durchgang geprüft und festgestellt, dass diese OL
"OL" bedeutet doch "kein Durchgang". Was hast Du denn erwartet, an diesen (nicht näher beschriebenen) Messpunkten?


Eine Frage habe ich aber trotzdem. Wie genau sieht das aus, wenn du sagts PBQ1 und 2 raus und probieren ob es lädt? Einfach die beiden überbrücken, so wie du es im Schnellkurs beschrieben hast?
KREISCH, NEIN!!!
(Mein Herz ...)
Fatal, doppelt fatal!

Als ich schrieb, Du könntest "PQB1 und PQB2 mal auslöten", da meinte ich genau das: auslöten!
Von Überbrücken schrieb ich nichts. Einfach ersatzlos raus!

Der Sinn dieser Maßnahme ist der, die ganze Ladeelektronik sozusagen abzuklemmen, vom Akku.
Die SMBus-Kommunikation wäre ja weiterhin gegeben, weil wir daran nicht rühren, ergo sollte der Akku sich vom Mainboard angesprochen fühlen und Saft liefern.
Über den BAT-Fet PQB13 könnte der (geladene) Akku dann ganz normal, wie im Akkubetrieb üblich, die Systemrail speisen, so dass die Funktionsfähigkeit des Akkubetriebs getestet werden kann.
Nur die Ladeelektronik hätten wir durch das Auslöten von PQB1 und PQB2 halt ganz aus dem Spiel raus.
Würde der Akkubetrieb also ohne diesen beiden MOSFETs funktionieren, dann wüssten wir, dass der Fehler in der Ladeelktronik angesiedelt sein muss.

Hättest Du aber (KREISCH!) die MOSFETs überbrückt, dann hättest Du die Systemrail voll nach Masse kurzgeschlossen!
Wenn da keine im Akku verbaute Schutzschaltung greift, dann würde im günstigsten Fall nur PQB13 abrauchen. Im ungünstigsten Fall würde der Akku ein Feuerwerk veranstalten und Dir die Bude abfackeln!


Stefan würde wahrscheinlich das "Vollbad" in Säure, Lauge, Wasser und Isopropanol empfehlen.
Ja, das hätte der Stafan in der Tat empfohlen, gleich ganz zu Anfang!
(Und übrigens beginnt die Reinigungsprozedur mit Lauge, noch vor der Säure. Sonst ist die Aufzählung korrekt.)

Und da KeinPlan offenbar echt keinen Plan hat (nicht böse gemeint), ergänze ich noch, dass das danach gut getrocknete Mainboard dann noch noch zusätzlich für mindestens 24 Stunden auf die Heizung gestellt werden muss, um ins Resin eindiffundiertes Wasser aus dem Material los zu werden, sonst tritt beim Löten der berüchtigte "Popcorn-Effekt" auf.
https://de.wikipedia.org/wiki/Popcorn-Effekt#Popcorn-Effekt

Selbst absurd langes Föhnen reicht nicht aus, um ins Material eindiffundiertes Wasser vollständig los zu werden, darum muss das Mainboard nach dem Föhnen unbedingt noch für mindestens 24 Stunden auf die Heizung gestellt werden.
Ich habe es oft genug erlebt, dass eine kürzere Trocknungsdauer nicht ausreichend ist; ganz egal wie staubtrocken die Oberfläche nach dem Föhnen schon lange ist.
Widerstehe der Versuchung, es nach bespielsweise nur 12 Stunden auf der Heizung zu probieren, Saft auf das Mainboard zu geben, oder daran zu löten! Betrachte 24 Stunden auf der Heizung als das Minimum, das niemals unterschritten werden darf.

Wenn all das durch ist, dann kommt eine abschließende, sehr kritische, optische Kontrolle beider Seiten. Und erst dann kommt erstmals der Lötkolben zum Einsatz.


Ich hätte wirklich erwartet, dass all diese Schritte bereits vor dem Startposting geschehen sind, angesichts des Vorstellungspostings im anderen Thread.
https://www.edv-dompteur.de/forum/index.…ad&threadID=727

Hätte ich einen reinen Anfänger erwartet, dann hätte ich das mit der Reinigung und Trocknung hier gleich zu Anfang geschrieben.
Unverständlich, dass nach ersten Lötereien noch korrodierte Stellen gefunden wurden!
Man macht zuerst alle korrodierten Stellen dingfest, bevor man mit der Löterei anfängt!
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte öffentlich im Forum stellen, nicht telefonisch! -

8

Donnerstag, 4. März 2021, 11:30

Bzgl. der Reinigung habt ihr Recht, das hätte vorher noch gründlicher durchgeführt werden müssen. Wie ich aber bereits schrieb, habe ich im Bereich Laptop-Mainboard noch nie etwas mit einem Feuchtigkeitsschaden gemacht. Bei den Sachen für die Handyboards, hatte meist eine Reinigung mit LR, oder wenn es ganz kritisch war auch mittels Ultraschallbad ausgereicht um von hier an mit der Rettung zu beginnen. Eine Reparatur mit Gewährleistung wurde von vornherein nicht angeboten. Hier handelte es sich lediglich um Datenrettungen, bei denen das Ergebnis bzgl. aller Funktionen nebensächlich war.
Da die Laptop-Platine nicht ins Ultraschallbad passt, konnte nur mittels LR die Reinigung durchgeführt werden.
Jedoch würde ich gerne mehr zur Reinigung mittels Lauge und Säure erfahren. Iso und LR Kontaktreiniger sind vorhanden.

Bzgl. des Überbrückens der Mosfets. Es ging mir hier um die Brücke von PQB 1 und nicht PQB 2 (direkt auf Masse). Da hatte sich mein Gehirn kurz ausgeklinkt und ich habe "beide" geschrieben. Da dies aber nun hinreichend geklärt wurde, hat sich auch die Frage erledigt.

Bedingt durch die aktuelle Situation übersieht man leider manchmal etwas und Sachen neben der täglichen Routine übersieht man dann leider andere Sachen. Die Kritik nehme ich aber sehr ernst und werde hier nachbessern.

Danke nochmals

EDV-Dompteur

Administrator

Beiträge: 1 938

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

9

Donnerstag, 4. März 2021, 13:47

Jedoch würde ich gerne mehr zur Reinigung mittels Lauge und Säure erfahren.
Lese dazu zunächst diesen Thread:
Kontaktspray, richtige Anwendung

Lese dann noch im Thread "Acer Predator PH317-51 - Keine +3VALWP" dieses Posting:
https://www.edv-dompteur.de/forum/index.…D=5031#post5031

Übrigens hat das Forum eine Suchfunktion. Diese Funktion mal mit dem Begriff "Säure" zu füttern, wäre doch ein erfolgsversprechender Ansatz gewesen, oder?
Tipp: Die Suchfunktion sollte immer von der Portalseite (Startseite) des Forums benutzt werden, nicht innerhalb eines offenen Threads. Denn nur dann wird das gesamte Forum durchsucht.


Bzgl. des Überbrückens der Mosfets. Es ging mir hier um die Brücke von PQB 1 und nicht PQB 2 (direkt auf Masse). Da hatte sich mein Gehirn kurz ausgeklinkt und ich habe "beide" geschrieben. Da dies aber nun hinreichend geklärt wurde, hat sich auch die Frage erledigt.
Nein, ich glaube das wurde offenbar noch nicht hinreichend geklärt ...

Erstens: Wenn Du nur PQB1 überbrückt hättest, dann würdest Du bei gleichzeitigem Betrieb von Netzteil & Akku doch die Spannung des Netzteils volle Pulle ungebremst auf den Akku knallen!
Der Akku hat aber eine geringere Lade-Endspannung, als die Netzteilspannung ...
Hätte der Akku keine eingebaute Überladungsschutzfunktion, dann würde er noch zuverlässiger und sogar noch heftiger ein Feuerwerk veranstalten, als er das bei Kurzschluss eventuell tun würde!

Zweitens: Der Sinn des Auslötens besteht gerade darin, es auszuschließen, dass über diesen Pfad Strom fließen kann.
Eine Überbrückung wäre das Gegenteil des Sinns hinter der Aktion.

Drittens: Für eine Überbrückung bräuchte man den MOSFET nicht langwierig per Heißluft auszulöten, sonden man könnte einfach ruckzuck mit dem Lötkolben eine Drahtbrücke direkt ans Bauteil anlöten.
Wäre das Ziel also eine Überbrückung gewesen, dann hätte ich genau das vorgeschlagen und nicht etwa das Auslöten.


Meine Worte sind wirklich in keinster Weise böse, oder zynisch gemeint, sondern ich möchte einfach nur erreichen, dass es Dir vollkommen klar wird, was die Aktion überhaupt soll und was dabei passiert.

Ich selbst wäre übrigens eh ganz anders vorgegangen, ohne Löterei; mein Vorschlag an Dich berücksichtigte Deinen Kenntnisstand und Deine Ausstattung. Ich ging davon aus, dass es Dir sicherlich sehr viel einfacher fallen würde, schnell mal zwei Bauteile auszulöten, als den Fehler "klassisch" zu suchen. Zumal ich dazu hätte Romane schreiben müssen.
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte öffentlich im Forum stellen, nicht telefonisch! -

Zur Zeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher